RCMF Donations

Enjoy using RCMF? How about a wee donation to help us keep you in the style to which you've become accustomed?

Welcome to RCMF. Please login or sign up.

December 03, 2020, 16:34:27 pm

Login with username, password and session length

Horus x10s with JR Dmss module

Started by MattR, March 30, 2018, 16:23:58 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

MattR

Hi Wondering if anyone can help, Ive got a Horus x10s running open tx and i want to use my JR Dmss module with it as i have lots of JR Rx's. I can't seem to get it to work and i think I'm doing something wrong rather than it just doesn't work with my set.
Thanks Matt.

Kevin Fairgrieve (NSS)

Open TX or FrOS?

If Open Tx have you selected the external module?

Kev

MattR

I'm running open tx, I turned on external module, I have tried it in ppm and all the other settings but no joy. The closest I've got is I reflashed the radio with mutimodule mode enabled, That gave me a Dm002 setting this sort of got the module working but I still can't bind a receiver to it.

Kevin Fairgrieve (NSS)

I only have a Spektrum module for my Horus, select PPm and away it goes first time.

If you have the time read this thread. https://www.rcgroups.com/forums/showthread.php?2727927-FrSky-Horus-X12S-A-new-beginning

Only 970 pages long at the moment. Loads of good advice and most of it applicable to the 10.

Kev


MattR

I'm a couple of hundred pages through that post, I'll let you know if I find anything.
Thanks for you help Kev.

Matt

frank


MattR

Hi Frank
Thanks for that, it's an interesting thing to check that I hadn't thought of.ive had the module light up but not consistently and the bind button doesn't seem to work. I will try it without it's case and see if the pins need tweaking.

Bad Raven

The first module I fitted to a X10 Taranis the pins missed the holes and went down the side of the insulation round the module sockets. Of course, that was hidden inside the well, vision blocked by the module.

It would help us help you if you fully listed what setting you have for the external module in OpenTX and any switches on the module. For example, have you got "bind on power up"  set on?
The user formerly know as Bravedan........... Well if Prince can do it....................

25wood

A member of my flying club has asked me to try to mend a Frsky x12s that he bought new only about six months ago. From what I understand he tried to load OpenTX onto the radio but did not make a backup of the original FROS system. The transmitter is completely 'black screened' only the charging light is on when charger plugged in. I have managed to 'wake up' the tranny by downloading the Open TX firmware to an SD card using Companion software. I refer to a previous post as below which mentioned a 'Mike(jet-flyer)' who has helped people on this forum reinstall FRsky original firmware under these circumstances. Any help with a walkthrough of the process or a method of contacting Mike would be appreciated .
FRSky horus discussions
Topic Horusx12s 'bricked
October 13, 2017, 15:50:13 PM
Re: Horus X12S bricked ? !
« Reply #16 on: October 15, 2017, 13:38:01 PM

tomkfly
Looked at your post and see Mike (Jet-flyer) has picked up your post. He is one of the guys that helped me and is the author of the instructions on the FrSky website.

25wood

Good Evening tomkfly Seen your reply but as yet Mike 9jet-flyer has not replied any idea if there is another way of contacting him. Regards

stukno

I did much the same when I first changed my X12 over to OTX. Dead as a Dodo.  V scary!

Print off the instructions from the OTX pages and then repeat the whole process but this time - do a meticulous check at every stage. Study the drawings, pictures and words and make sure that you have every box ticked at each stage as per the instruction process.

At some point in the process you have to load and use another programme, can't just remember the name at this moment and I don't have time to look it up now.  Begins with Z?  Windows has a habit of corrupting the settings. Make sure that that is set correctly.

On my second attempt, I got it right and the TX fired up exactly as advertised.

With considerable trepidation, I later changed from OTX 2.2.0 to 2.2.1 and it went right first time.


Good Luck, it is worth it in the end
regards

stu k

Kevin Fairgrieve (NSS)

The program you refer to is Zadig.

https://zadig.akeo.ie/

A USB driver install program.



HTH

Kev


25wood

I have managed to upload a dfu file to the tranny using companion. Held the power button down, Updating started, Note- Flash done, 'welcome to HorUs'. Then downloaded the latest bin file eu1503 frtx to an sd card did an update so the tranny is now reporting
Hardware X12S EU14
Software 1.5.03
Unfortunately the opening screen is not the expected HORUS splash screen but when the tranny is switched on it goes straight to 'create model'. When I try to create the first model it asks me to load what I have entered and then displays a dialog box 'config file is not exist' . CANNOT GET PAST THIS. I can get into the 'SYSTEM' 'MODEL' And 'Telemetry' screens to no avail. Help Ive been on this for too long!